Windows 7 Pre SP1 failed

Windows 7 Releases Both (x86) And (x64)
deadmanwalking
Posts: 5
Joined: Wed Jun 29, 2016 4:09 pm

Windows 7 Pre SP1 failed

Postby deadmanwalking » Wed Jun 29, 2016 4:17 pm

Hi I have just been rebuilding an old lenovo dualcore pc and have decided to give autopatcher a go as windows update sucks on old kit, what with memory leaks and slow performance.

I have pasted a screenshot of where it had got to and pasted a copy of the log, it would seem that autopatcher is triong to install patches (.net) that have a prerequisit of SP1 before SP1 has been installed.

Image
► Show Spoiler
Last edited by Whatacrock on Thu Jun 30, 2016 1:55 am, edited 1 time in total.
Reason: spoiler code used

User avatar
Whatacrock
Release Maintainer
Release Maintainer
Posts: 1967
Joined: Mon Oct 28, 2013 10:47 am
Location: Australia
Contact:

Re: Windows 7 Pre SP1 failed

Postby Whatacrock » Thu Jun 30, 2016 2:03 am

All Windows Seven updates are designed for updating Service Pack 1, there are many that will install without it but more advisable to install SP1 before using Autopatcher. SP1 can be downloaded from https://www.microsoft.com/en-us/downloa ... px?id=5842 do be aware these are extra large files decision is yours..

One note though, if you install the rollup package (KB3161608) for June 2016, this will fix the issues with Windows Update (successfully repaired the issue on 2 machines)
"Now if you Sons of B*@ches got anything else to say, NOW'S THE F@#%ING TIME!!"

ChrisJ
Posts: 351
Joined: Sun Oct 27, 2013 3:32 am

Re: Windows 7 Pre SP1 failed

Postby ChrisJ » Thu Jun 30, 2016 5:56 am

Hi Wac :)

Not sure if you noticed this from dmw's log above...

code snip:

Code: Select all

Module '\Components\__dotnet\NDP46-KB3143693-x86.apm' EXPLICITLY refers to its module folder as \Components\__dotnet\dotNET-x64_files'. However, such folder does not exist!

Error Detected: File not found in RunCommand At Line 104
Attempted Commandline: "\Components\__dotnet\dotNET-x64_files\NDP46-KB3143693-x86.exe" /quiet /norestart
NDP46-KB3143693-x86.apm is looking for \dotNET-x64_files\ - thought I'd bring it to your attention.

User avatar
Whatacrock
Release Maintainer
Release Maintainer
Posts: 1967
Joined: Mon Oct 28, 2013 10:47 am
Location: Australia
Contact:

Re: Windows 7 Pre SP1 failed

Postby Whatacrock » Thu Jun 30, 2016 9:03 am

@ChrisJ -- I did notice when applying the spoiler and completely forgot about it thereafter. Have now corrected the issue and uploaded to server, no date change... :oops: :oops:
"Now if you Sons of B*@ches got anything else to say, NOW'S THE F@#%ING TIME!!"

deadmanwalking
Posts: 5
Joined: Wed Jun 29, 2016 4:09 pm

Re: Windows 7 Pre SP1 failed

Postby deadmanwalking » Thu Jun 30, 2016 9:23 am

Thanks Guys, I have applied SP1 and re downloaded the patches with Autopatcher, looking good so far currently at 48 of 138 52 min (Est) remaining.

Suspect I will have to do more downloads after this reboot.

Cheers All

deadmanwalking
Posts: 5
Joined: Wed Jun 29, 2016 4:09 pm

Re: Windows 7 Pre SP1 failed

Postby deadmanwalking » Thu Jun 30, 2016 10:32 am

Oh Dear, its failed again, am I doing something dumb? :oops: here's the details:

Image
► Show Spoiler
Last edited by deadmanwalking on Thu Jun 30, 2016 1:12 pm, edited 1 time in total.

deadmanwalking
Posts: 5
Joined: Wed Jun 29, 2016 4:09 pm

Re: Windows 7 Pre SP1 failed

Postby deadmanwalking » Thu Jun 30, 2016 1:02 pm

In order to get past this issue I have had to turned off all .net updates, on doing so I did notice that the .net 4.6 full installer was neither blue or ticked so it was trying to install updates when the full installation has not even been installed yet.

I have now found another issue, when installing the recomended apdates after the critical ones were all complete I get a popup windows for Internet explorer setup command line switches

Image
► Show Spoiler

deadmanwalking
Posts: 5
Joined: Wed Jun 29, 2016 4:09 pm

Re: Windows 7 Pre SP1 failed

Postby deadmanwalking » Thu Jun 30, 2016 2:21 pm

The reboot after the recomended updates gives the following screenshot and log below:

Image
► Show Spoiler

ChrisJ
Posts: 351
Joined: Sun Oct 27, 2013 3:32 am

Re: Windows 7 Pre SP1 failed

Postby ChrisJ » Thu Jun 30, 2016 4:17 pm

DMW

1) - Update AP to 6.2.6. - see the releases list in AP.
2) - Update your .Net x86 release to get the fixed apm for .Net 4.6.1 (KB3143693).
3) - Don't install major versions of software (IE11) while installing other updates, pending reboots can't be waiting and certain updates need to already be in place - this is the safe way... Major versions install alone, by themselves, not buried in 170 other updates.
4) IE 11 has prerequisites before it can be installed - see link below... There are recommended updates too, not needed but recommended for an easier install. These updates need to be in place already, and the OS rebooted.
5) Screenshots are helpful if they include a popup error or detailed information, in this case your AP log is more detailed. You don't need to post a screenshot of AutoPatcher installing updates. The others are helpful.

IE11 Requirements - https://support.microsoft.com/en-us/kb/2847882
IE11 Install Troubleshooting - https://support.microsoft.com/en-us/kb/2872074

So, skip .Net 4.6.1. (for now), and get any IE11 prerequisites in place (first) before installing IE11. Also, IMO, you want to install fewer updates in a single run, AP is designed as a convienant way to update a system, plus it's portable and reusable so you can put it on a thumb drive or dvd and update other computers - it's not trying to win a race or meant as a way to install everything At Once - drop a few reboots in there :)

These are my suggestions. TAPG & Wac will likely provide feedback for you as well, on how to proceed and get your system updated and fix the errors.

Update: .Net 4.6.1 (KB3143693, x86) looks to be fixed, I checked the script and the apm, both point to \dotNET-x86_files\, so this update should install if you update the release first to get the updated apm file. I also was vegging a bit and assumed 4.6.1. was the full installer, not simply a secuirty update - my mistake.

User avatar
TheAPGuy
Site Admin
Site Admin
Posts: 966
Joined: Sun Oct 27, 2013 12:38 am
Location: California
Contact:

Re: Windows 7 Pre SP1 failed

Postby TheAPGuy » Fri Jul 01, 2016 1:46 am

Follow ChisJ's suggestions and then report back.


Return to “Windows 7”

Who is online

Users browsing this forum: No registered users and 1 guest