RTI/script mismatch?

Extra includes several programs. Prominent ones are Shockwave, Flashplayer, Silverlight(MS IE addon), Some XP Powertoys, and TweakUI
undro
Posts: 36
Joined: Fri May 09, 2014 2:36 am

RTI/script mismatch?

Postby undro » Tue May 20, 2014 10:57 pm

I think there's a mismatch between the RTI and script, or something of the sort.

APUP says there are missing files:

Code: Select all

***Starting Detection Routine Phase***

Missing file D:\autopatcher2\modules\AddOns\dxcpl_enu.apm
Missing file D:\autopatcher2\modules\AddOns\dxcpl_files\directx.cpl
Missing file D:\autopatcher2\modules\AddOns\dxcpl_files\dxcpl.apf
Missing file D:\autopatcher2\modules\AddOns\dxcpl_files\Undo_dxcpl.apf
Missing file D:\autopatcher2\modules\AddOns\USMTool_x86_enu.apm
Missing file D:\autopatcher2\modules\AddOns\NetworkMonitor_x86.apm
Missing file D:\autopatcher2\modules\AddOns\NetworkMonitor_x64.apm
Missing file D:\autopatcher2\modules\AddOns\fontprop_enu.apm
Missing file D:\autopatcher2\modules\AddOns\mdm.apm
Missing file D:\autopatcher2\modules\AddOns\CleartypePowertoy.apm
Item AutoPatcher Extras Modules is missing or its parts are not completely downloaded. Adding whole download for this item to the queue.
--Adding http://www.autopatcher.net/releases/extras/_windows_extras_20140418.7z--

***Downloading Releases***

Files to be Downloaded: 1
Download queue processed. Proceeding to next phase.

***Processing Cleanup Routines***

Extracting D:\autopatcher2\temp_bin\_windows_extras.7z into D:\autopatcher2\modules\
And Sweeper wants to delete the ones that are downloaded:

Code: Select all

Script: Extras Is In UnOfficial Status. If You Do Not See Why Above And Want To Know Why,
Run Sweeper.exe with /verbose CommandLine
EXTRA FILE: '..\modules\CleartypePowertoy.apm
EXTRA FILE: '..\modules\dxcpl_enu.apm
EXTRA FILE: '..\modules\fontprop_enu.apm
EXTRA FILE: '..\modules\mdm.apm
EXTRA FILE: '..\modules\NetworkMonitor_x64.apm
EXTRA FILE: '..\modules\NetworkMonitor_x86.apm
EXTRA FILE: '..\modules\stand_alone.apm
EXTRA FILE: '..\modules\USMTool_x86_enu.apm
EXTRA FILE: '..\modules\CleartypePowertoy_files\CleartypePowertoySetup.exe
EXTRA FILE: '..\modules\dxcpl_files\directx.cpl
EXTRA FILE: '..\modules\dxcpl_files\dxcpl.apf
EXTRA FILE: '..\modules\dxcpl_files\Undo_dxcpl.apf
EXTRA FILE: '..\modules\fontprop_enu.apm_files\setup.exe
EXTRA FILE: '..\modules\mdm_files\MSDownloadManager.msi
EXTRA FILE: '..\modules\NetworkMonitor_x64.apm_files\NM34_x64.exe
EXTRA FILE: '..\modules\NetworkMonitor_x86.apm_files\NM34_x86.exe
EXTRA FILE: '..\modules\USMTool_files\InstallUSMT301_x86.msi

User avatar
Whatacrock
Release Maintainer
Release Maintainer
Posts: 1967
Joined: Mon Oct 28, 2013 10:47 am
Location: Australia
Contact:

Re: RTI/script mismatch?

Postby Whatacrock » Wed May 21, 2014 12:10 am

@undro --- try running apup again to download the extras release, do not select any others. This should fix your issue.
"Now if you Sons of B*@ches got anything else to say, NOW'S THE F@#%ING TIME!!"

undro
Posts: 36
Joined: Fri May 09, 2014 2:36 am

Re: RTI/script mismatch?

Postby undro » Wed May 21, 2014 12:55 am

Tried that, same thing.

One thing I see is that:

http://www.autopatcher.net/releases/ext ... 0140418.7z is extracted to modules\, and the files inside that 7z start at the root.

The Detect* directives in http://www.autopatcher.net/releases/ext ... 513.script all refer to files under modules\AddOns.

User avatar
Whatacrock
Release Maintainer
Release Maintainer
Posts: 1967
Joined: Mon Oct 28, 2013 10:47 am
Location: Australia
Contact:

Re: RTI/script mismatch?

Postby Whatacrock » Wed May 21, 2014 12:58 am

Will double check that particular archive, and report back
"Now if you Sons of B*@ches got anything else to say, NOW'S THE F@#%ING TIME!!"

User avatar
Whatacrock
Release Maintainer
Release Maintainer
Posts: 1967
Joined: Mon Oct 28, 2013 10:47 am
Location: Australia
Contact:

Re: RTI/script mismatch?

Postby Whatacrock » Wed May 21, 2014 1:28 am

Thanks undro for pointing out the error in my ways.... I'M A BAD MAN !!!!!

Have corrected the issue and uploaded, the release has a new date 20140521
"Now if you Sons of B*@ches got anything else to say, NOW'S THE F@#%ING TIME!!"

undro
Posts: 36
Joined: Fri May 09, 2014 2:36 am

Re: RTI/script mismatch?

Postby undro » Wed May 21, 2014 1:31 am

Thanks.

Why are you always a bad man? :)

User avatar
Whatacrock
Release Maintainer
Release Maintainer
Posts: 1967
Joined: Mon Oct 28, 2013 10:47 am
Location: Australia
Contact:

Re: RTI/script mismatch?

Postby Whatacrock » Wed May 21, 2014 3:17 am

Keep making errors !!!

A small amendment made to the windows extras archive, left a moved apm module behind, does not affect as sweeper will take care of it
"Now if you Sons of B*@ches got anything else to say, NOW'S THE F@#%ING TIME!!"


Return to “Extras”

Who is online

Users browsing this forum: No registered users and 2 guests