.Net Framework Question

parkd1
Moderator
Moderator
Posts: 330
Joined: Tue Jan 07, 2014 4:33 pm

Re: .Net Framework Question

Postby parkd1 » Sat May 17, 2014 5:51 pm

Thanks a lot.

vezon
Posts: 3
Joined: Mon Mar 20, 2017 7:54 am

Re: .Net Framework Question

Postby vezon » Tue Mar 28, 2017 8:22 am

I'm a bit puzzled about .NET packages and updates.
If I have installed .NET Framework 3.5SP1 which says that it contains 2.0 and 3.0, do u need to install .NET 2.0 updates?
If yes, why do I get errors when I try to install them (for ex KB958481)?

User avatar
TheAPGuy
Site Admin
Site Admin
Posts: 966
Joined: Sun Oct 27, 2013 12:38 am
Location: California
Contact:

Re: .Net Framework Question

Postby TheAPGuy » Wed Mar 29, 2017 1:59 am

Wiki (the totally never wrong source of ALL information) says the next higher version of .NET is meant to replace the lower one... not necessarily that it "contains" the lower one. https://en.wikipedia.org/wiki/.NET_Fram ... se_history
You will note in that link the versions that are replaced with each new update. .NET 1.1 NEVER gets replaced... weird huh? Guess we should all go and install it.

Anyways... from what I have experienced there is backwards compatibility built into the higher versions for the apps that want the lower versions. I don't know about anything past 3.5 though... I uninstalled my 2.0 when I got 3.5 installed.


Return to “Microsoft .NET Framework”

Who is online

Users browsing this forum: No registered users and 1 guest