DOTNET4_PARENT missing or wrong order?

undro
Posts: 36
Joined: Fri May 09, 2014 2:36 am

DOTNET4_PARENT missing or wrong order?

Postby undro » Tue May 20, 2014 11:48 pm

AP's log file reports this:

Code: Select all

Module 'Microsoft .NET Framework 4 (Standalone Installer)' (unique id: 'dotNetFx40_Full_x86_x64') reports 'DOTNET4_PARENT' as its parent, but such module does not exist or is not loaded in the right order.
Module 'Update for the .NET Framework 4 (KB2468871-v2)' (unique id: 'NDP40-KB2468871-v2-x86') reports 'DOTNET4_PARENT' as its parent, but such module does not exist or is not loaded in the right order.
Module 'Reliability Update 1 for the .NET Framework 4 (KB2533523)' (unique id: 'NDP40-KB2533523-x86') reports 'DOTNET4_PARENT' as its parent, but such module does not exist or is not loaded in the right order.
Module 'Reliability Update 2 for the .NET Framework 4 (KB2600217)' (unique id: 'NDP40-KB2600217-x86') reports 'DOTNET4_PARENT' as its parent, but such module does not exist or is not loaded in the right order.
Module 'Update 4.0.3 for Microsoft .NET Framework 4 Runtime Update (KB2600211)' (unique id: 'NDP40-KB2600211-x86-x64') reports 'DOTNET4_PARENT' as its parent, but such module does not exist or is not loaded in the right order.
Module 'Security Update for Microsoft .NET Framework 4 on XP, Server 2003, Vista, and Server 2008 (KB2604121)' (unique id: 'NDP40-KB2604121-x86') reports 'DOTNET4_PARENT' as its parent, but such module does not exist or is not loaded in the right order.
Module 'Security Update for Microsoft .NET Framework 4 on XP, Server 2003, Vista, Server 2008, Windows 7, and Server 2008 R2 (KB2729449)' (unique id: 'NDP40-KB2729449-x86') reports 'DOTNET4_PARENT' as its parent, but such module does not exist or is not loaded in the right order.
Module 'Security Update for Microsoft .NET Framework 4 on XP, Server 2003, Vista, Server 2008, Windows 7, and Server 2008 R2 (KB2737019)' (unique id: 'NDP40-KB2737019-x86') reports 'DOTNET4_PARENT' as its parent, but such module does not exist or is not loaded in the right order.
Module 'Security Update for Microsoft .NET Framework 4 on XP, Server 2003, Vista, Server 2008, Windows 7, and Server 2008 R2 (KB2736428)' (unique id: 'NDP40-KB2736428-x86') reports 'DOTNET4_PARENT' as its parent, but such module does not exist or is not loaded in the right order.
Module 'Security Update for Microsoft .NET Framework 4 on XP, Server 2003, Vista, Server 2008, Windows 7, and Server 2008 R2 (KB2742595)' (unique id: 'NDP40-KB2742595-x86') reports 'DOTNET4_PARENT' as its parent, but such module does not exist or is not loaded in the right order.
Module 'Security Update for Microsoft .NET Framework 4 on XP, Server 2003, Vista, Server 2008, Windows 7, and Server 2008 R2 (KB2789642)' (unique id: 'NDP40-KB2789642-x86') reports 'DOTNET4_PARENT' as its parent, but such module does not exist or is not loaded in the right order.
Module 'Security Update for Microsoft .NET Framework 4 on XP, Server 2003, Vista, Server 2008, Windows 7, and Server 2008 R2 (KB2840628-v2)' (unique id: 'NDP40-KB2840628-v2-x86') reports 'DOTNET4_PARENT' as its parent, but such module does not exist or is not loaded in the right order.
Module 'Security Update for Microsoft .NET Framework 4 on XP, Server 2003, Vista, Server 2008, Windows 7, and Server 2008 R2 (KB2858302-v2)' (unique id: 'NDP40-KB2858302-v2-x86') reports 'DOTNET4_PARENT' as its parent, but such module does not exist or is not loaded in the right order.
Module 'Security Update for Microsoft .NET Framework 4 on XP, Server 2003, Vista, and Server 2008 (KB2861188)' (unique id: 'NDP40-KB2861188-x86') reports 'DOTNET4_PARENT' as its parent, but such module does not exist or is not loaded in the right order.
Module 'Security Update for Microsoft .NET Framework 4 on XP, Server 2003, Vista, Server 2008, Windows 7, and Server 2008 R2 (KB2894842)' (unique id: 'NDP40-KB2894842-x86') reports 'DOTNET4_PARENT' as its parent, but such module does not exist or is not loaded in the right order.
Module 'Security Update for Microsoft .NET Framework 4 on XP, Server 2003, Vista, Server 2008, Windows 7, and Server 2008 R2 (KB2901110-v2)' (unique id: 'NDP40-KB2901110-v2-x86') reports 'DOTNET4_PARENT' as its parent, but such module does not exist or is not loaded in the right order.
Module 'Security Update for Microsoft .NET Framework 4 on XP, Server 2003, Vista, Server 2008, Windows 7, and Server 2008 R2 (KB2898855)' (unique id: 'NDP40-KB2898855-v2-x86') reports 'DOTNET4_PARENT' as its parent, but such module does not exist or is not loaded in the right order.

User avatar
click-click
Release Maintainer
Release Maintainer
Posts: 55
Joined: Mon Jan 06, 2014 1:52 pm

Re: DOTNET4_PARENT missing or wrong order?

Postby click-click » Wed May 21, 2014 10:31 am

These are not errors and has to do with hiding dotNET 4 which is currently only supported under XP.
I'm not young enough to know everything

undro
Posts: 36
Joined: Fri May 09, 2014 2:36 am

Re: DOTNET4_PARENT missing or wrong order?

Postby undro » Wed May 21, 2014 7:50 pm

This is on XP, without dotNET4 installed. I guess the problem is this, in __dotnet40.apm:

Code: Select all

# Do not display 4.0 if updated with 4.5
ComponentFile=windows:\Microsoft.NET\Framework\v4.0.30319\WPF\PresentationFramework.Aero.dll
ComponentVersion=<4.0.30319.17929
The component doesn't show if this file doesn't exist.

And I guess v4 isn't only for XP, but for anything without v4.5?
The APM includes WindowsVersion=XP,2K3,VISTA,LHSERVER,SEVEN. Also the very verbatim updates above mention XP-Server2008.

BTW, something unrelated I noticed. It's just "visual", but may lead to future mixups. In autopatcher_dotNET_x86_20140513.script, WindowsXP-KB961118-x86-ENU.exe is listed under the heading "Start of .NET 3.5 Family .msu Updates (Windows 7)" instead of "Start of .NET 3.5 SP1 .exe Updates".

User avatar
click-click
Release Maintainer
Release Maintainer
Posts: 55
Joined: Mon Jan 06, 2014 1:52 pm

Re: DOTNET4_PARENT missing or wrong order?

Postby click-click » Thu May 22, 2014 11:45 am

The __dotnet40.apm is only valid for XP with dotNET. The logic was never changed as mentioned here and here. This apm will likely be removed in the future.

A lot of these APMs have been around for a long time and some things left unchanged - XP Server 2008 is not supported. Yes, some things need to be cleaned up, but we are far and few between. Would you like to volunteer?

4.0 is only for XP because that was the the last supported version for XP. All other systems running 4.0 are not supported since 4.0 has been superseded by a newer version. The dotNET script only supports the latest version
because we simply do not have the resources to support every release, so you if you need something other than that there's always Windows Update.

Since the scripts are not files that should concern the normal user - "may lead to future mixups" for who?
I'm not young enough to know everything

undro
Posts: 36
Joined: Fri May 09, 2014 2:36 am

Re: DOTNET4_PARENT missing or wrong order?

Postby undro » Mon May 26, 2014 9:31 am

I could cleanup the current version, but I'm not that fluent in MS patch peculiarities so you'll have to tell me more specifically what sort of cleanup you have in mind. I don't use AP for any bulk or regular updating, just wanted to keep a static XP "SP4" for the future.

Is there no way to hide that update if 4.5 is installed yet show it if not, maybe with the extra stipulation that it must be NT5?

Mixups, I meant for the maintainer. It's easy to gloss over the details and just do some bulk edit based on the section titles.

widhie75
Posts: 26
Joined: Tue Apr 08, 2014 6:29 am

Re: DOTNET4_PARENT missing or wrong order?

Postby widhie75 » Sun Jun 01, 2014 9:56 am

I also found that .NET Framewok 4.0 is hidden.
My OS: Windows XP SP3 - 32 bit

I already install .NET 1.1 - 3.5 but still .NET 4 doesn't appear in AutoPatcher.
So, I do manually run "dotNetFx40_Full_x86_x64.exe" inside folder "\modules\Components\__dotnet\dotNET-x86-x64_files"

After manually run it and success installing,,,, all security updates for .NET 4.0 appeared normal inside autoPatcher.

Maybe this .NET 4 hidden issue because there's already latest .NET 4.5 release (just like click-click said?)

----------------------

@click-click , About your comment "This apm will likely be removed in the future. "
so, what happen next with .NET updates? ....... is it will be removed and AutoPatcher will not support .NET anymore?

User avatar
Whatacrock
Release Maintainer
Release Maintainer
Posts: 1967
Joined: Mon Oct 28, 2013 10:47 am
Location: Australia
Contact:

Re: DOTNET4_PARENT missing or wrong order?

Postby Whatacrock » Sun Jun 01, 2014 12:26 pm

@widhie75 --- As you are probably aware by now most updates install silently, that is to say without user interaction.

However there are those that do require interaction from the user and one of these being dotNetFx40_Full_x86_x64.exe.

Once the stand alone installer has been run, and autopatcher restarted then the relevant additional become visible for the user to install.

As far as what happens to the .NET updates they will continue to be added, but am uncertain of click-click's intentions for the .NET 4.0 updates that are currently relevant to Windows XP .

This will more than likely become a discussion topic in the future...
"Now if you Sons of B*@ches got anything else to say, NOW'S THE F@#%ING TIME!!"

User avatar
click-click
Release Maintainer
Release Maintainer
Posts: 55
Joined: Mon Jan 06, 2014 1:52 pm

Re: DOTNET4_PARENT missing or wrong order?

Postby click-click » Mon Jun 02, 2014 12:14 pm

I also found that .NET Framewok 4.0 is hidden.

@click-click , About your comment "This apm will likely be removed in the future. "
so, what happen next with .NET updates? ....... is it will be removed and AutoPatcher will not support .NET anymore?
AP supports .NET, but only for the latest versions. That being 1.1, 3.5 family and 4.5.2 where applicable. Since XP is EOL,
any new updates to .NET 4.0 will not be officially supported for use with XP by Microsoft and neither can we. Most likely the new updates would work, but you are on your own when something breaks. I am considering removing only the dotnet 40 apm or possibly leaving it there for XP-only at a frozen state with the last applicable updates prior to May 2014.
I'm not young enough to know everything


Return to “Microsoft .NET Framework”

Who is online

Users browsing this forum: No registered users and 3 guests