Autopatcher v6.2

In this area, you will find test programs and scripts.
User avatar
Whatacrock
Release Maintainer
Release Maintainer
Posts: 1967
Joined: Mon Oct 28, 2013 10:47 am
Location: Australia
Contact:

Re: Autopatcher v6.2

Postby Whatacrock » Fri Nov 11, 2016 12:57 pm

@the madkansan -- refer to this for solution to your issue
viewtopic.php?f=4&t=1449

Remember if it is the first time running autopatcher, you must "Run As Administrator"
"Now if you Sons of B*@ches got anything else to say, NOW'S THE F@#%ING TIME!!"

User avatar
TheAPGuy
Site Admin
Site Admin
Posts: 915
Joined: Sun Oct 27, 2013 12:38 am
Location: California
Contact:

Re: Autopatcher v6.2

Postby TheAPGuy » Fri Nov 11, 2016 4:48 pm

Reminds me to put that detection in for running in admin mode or not, also the ocx detection. Should have that done today.

User avatar
TheAPGuy
Site Admin
Site Admin
Posts: 915
Joined: Sun Oct 27, 2013 12:38 am
Location: California
Contact:

Re: Autopatcher v6.2

Postby TheAPGuy » Fri Nov 11, 2016 9:24 pm

New version attached... just the exe. This one is also special compiled for DJ so it will be a bit slower doing MD5 checks.
New to this version: 6.2.15
Checks for ADMIN rights... if its run with admin rights it will say ! ADMIN ! in the title (will warn you when you go to install screen if you did NOT run as admin)
It will also check if your OCX files are installed and TRY to install them if not. (it used to look for the files in your system directory every time it was run before. Problem is just because the files were there... that didn't mean they were registered. Now we will know if they are.)
New switch to skip to install screen... /skiptoinstall
Attachments
AutoPatcher.7z
(129.06 KiB) Downloaded 47 times

themadkansan
Posts: 44
Joined: Tue Jan 07, 2014 8:25 am

Re: Autopatcher v6.2

Postby themadkansan » Sat Nov 12, 2016 12:55 am

@the madkansan -- refer to this for solution to your issue
viewtopic.php?f=4&t=1449

Remember if it is the first time running autopatcher, you must "Run As Administrator"
I did. I always do now. gets the same crash and error whether it has admin rights or not.

User avatar
TheAPGuy
Site Admin
Site Admin
Posts: 915
Joined: Sun Oct 27, 2013 12:38 am
Location: California
Contact:

Re: Autopatcher v6.2

Postby TheAPGuy » Sat Nov 12, 2016 1:58 am

and the new one too?

themadkansan
Posts: 44
Joined: Tue Jan 07, 2014 8:25 am

Re: Autopatcher v6.2

Postby themadkansan » Sat Nov 12, 2016 2:31 am

and the new one too?
Just tried it on a fresh wipe-and-install:

The admin warning trips as expected, but when I run it as admin, it's getting stuck at the "You are missing OCX files..." message and just keeps repeating it whenever I click OK. Whether I click OK or X, it just refreshes the message popup. I have to kill it through TaskManager.

6209 runs correctly with Admin rights from the same point.

User avatar
TheAPGuy
Site Admin
Site Admin
Posts: 915
Joined: Sun Oct 27, 2013 12:38 am
Location: California
Contact:

Re: Autopatcher v6.2

Postby TheAPGuy » Sat Nov 12, 2016 4:16 am

hmmm... Does the log say anything interesting?

themadkansan
Posts: 44
Joined: Tue Jan 07, 2014 8:25 am

Re: Autopatcher v6.2

Postby themadkansan » Sat Nov 12, 2016 4:28 am

hmmm... Does the log say anything interesting?
AutoPatcher v6.2.15 ! ADMIN ! Has Started at 11/11/2016 8:26:21 PM

Starting Autopatcher From C:\Users\x\Desktop\AutoPatcher-v6_2_14-111016

Checking if OCX Files are registered.

You are missing OCX Files that need to be installed.
This is normal for a first run. If this is not your first run contact the Autopatche.net.
We will attempt to copy the needed files and register them.

Error Detected: Object variable or With block variable not set in APInitialize.dllSelfRegister At Line 0

and just repeats after that.

User avatar
TheAPGuy
Site Admin
Site Admin
Posts: 915
Joined: Sun Oct 27, 2013 12:38 am
Location: California
Contact:

Re: Autopatcher v6.2

Postby TheAPGuy » Sat Nov 12, 2016 5:20 am

ok so I went to check that location in the code and guess what... I lost all of today's work. :( I was transferring everything to a new HD and it transferred over seemingly fine. Games worked, other things looked fine... I wiped old drive. I happened to be using the VM when I was doing the copy. It did NOT save the changed state files. So... ya. I have to redo the code tomorrow for the changes I did today. :(

themadkansan
Posts: 44
Joined: Tue Jan 07, 2014 8:25 am

Re: Autopatcher v6.2

Postby themadkansan » Sat Nov 12, 2016 7:00 am

...um, owie? :shock:


Return to “Testing”

Who is online

Users browsing this forum: No registered users and 2 guests