Autopatcher won"t start

Requests for help go in here.
vkozak
Posts: 8
Joined: Mon Nov 07, 2016 4:55 pm

Autopatcher won"t start

Postby vkozak » Mon Nov 07, 2016 5:00 pm

Hi. I'm a first time user. Windows 7 x64. I downloaded and unzipped the autopatcher file. Tried to run the exe and got the following error.
Run Time Error 339. Component RICHTX32.ocx or one of it's dependencies not correctly registered. A file is missing or invalid.

Downloaded and unzipped twice with the same result.

User avatar
Whatacrock
Release Maintainer
Release Maintainer
Posts: 1967
Joined: Mon Oct 28, 2013 10:47 am
Location: Australia
Contact:

Re: Autopatcher won"t start

Postby Whatacrock » Tue Nov 08, 2016 1:02 am

@vkozak -- firstly Welcome

The first time you run Autopatcher, this MUST be done as administrator. This will register the runtimes files.
"Now if you Sons of B*@ches got anything else to say, NOW'S THE F@#%ING TIME!!"

User avatar
TheAPGuy
Site Admin
Site Admin
Posts: 917
Joined: Sun Oct 27, 2013 12:38 am
Location: California
Contact:

Re: Autopatcher won"t start

Postby TheAPGuy » Tue Nov 08, 2016 1:27 am

hmm... Maybe I should make an installer for first time users? There also might be a way to check if the ocx files are registered and bail out if not while giving a good reason why instead of Yikes crash screen.

vkozak
Posts: 8
Joined: Mon Nov 07, 2016 4:55 pm

Re: Autopatcher won"t start

Postby vkozak » Tue Nov 08, 2016 1:44 am

I wish it were that simple. I ran the exe file as administrator with the same results.

vkozak
Posts: 8
Joined: Mon Nov 07, 2016 4:55 pm

Re: Autopatcher won"t start

Postby vkozak » Tue Nov 08, 2016 1:46 am

Thanks for the welcome! Exactly the same error message showed up when running the exe as administrator.

User avatar
TheAPGuy
Site Admin
Site Admin
Posts: 917
Joined: Sun Oct 27, 2013 12:38 am
Location: California
Contact:

Re: Autopatcher won"t start

Postby TheAPGuy » Tue Nov 08, 2016 3:02 am

right click on your desktop.
select new
Select make a shortcut.
type in cmd
Select next
Select finish
CMD is command. Its a dos box to run commands with.
Double click that link.

type the next line in or copy paste it in.
reg query HKCR\typelib "{3B7C8863-D78F-101B-B9B5-04021C009402}"

If it finds that RICHTX32.ocx is registered it will show "1 match found"


side note...
I will be adding this kind of detection to AP. AP will run these checks before even opening the log file.

RICHTX32
Posts: 1
Joined: Tue Nov 08, 2016 3:29 am

Re: Autopatcher won"t start

Postby RICHTX32 » Tue Nov 08, 2016 3:34 am

Go to ocxdump.com/zip/ocxfiles/R/RICHTX32.zip <-- edited by TheAPGuy to remove auto link. They can copy paste it if they really want to go there.
UnZip and place dll in mine folder of AutoPatcher.exe
Thx for attetion and BB

User avatar
TheAPGuy
Site Admin
Site Admin
Posts: 917
Joined: Sun Oct 27, 2013 12:38 am
Location: California
Contact:

Re: Autopatcher won"t start

Postby TheAPGuy » Tue Nov 08, 2016 4:47 am

Autopatcher comes with all the needed files to run. If the files are not getting copied and registered... that a different problem.

vkozak
Posts: 8
Joined: Mon Nov 07, 2016 4:55 pm

Re: Autopatcher won"t start

Postby vkozak » Tue Nov 08, 2016 4:36 pm

No joy. I pasted the command in the dos box (which came up in the C:\windows\system32 directory) and received: ERROR: Invalid syntax. Type "REG QUERY /?: for usage.

artemisevans
Posts: 2
Joined: Tue Nov 08, 2016 5:48 pm

Re: Autopatcher won"t start

Postby artemisevans » Tue Nov 08, 2016 5:51 pm

I don't know if there was an update and it just wasn't compiled right, but this worked for me. I was getting the same error and it looked like it just couldn't find the file. I copied everything from the bin folder into the main folder where autopatcher.exe resides; so the files are no longer in a subfolder. Then run autopatcher as admin. Voila.


Return to “Help”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests