Run-time error 13: Type mismatch

Requests for help go in here.
Jarry
Posts: 1
Joined: Sun Jun 26, 2016 4:55 pm

Run-time error 13: Type mismatch

Postby Jarry » Sun Jun 26, 2016 5:00 pm

I have been using autopatcher for patching Win7/64b for quite some time without any problem, but with the latest update (v6.2.2) I always get this error message whenever I click on some update-pack to see info:

Run-time error '13':

Type mismatch


And all I can do is to click "OK" and autopatcher is closed. When I copy the old autopatcher-binary (v6.1.32) over the new one, I have no problem and can proceed as usual. How can I fix it?

User avatar
TheAPGuy
Site Admin
Site Admin
Posts: 968
Joined: Sun Oct 27, 2013 12:38 am
Location: California
Contact:

Re: Run-time error 13: Type mismatch

Postby TheAPGuy » Sun Jun 26, 2016 11:55 pm

Can you post the log please. You will find it in one of two places... First and most likely is the same directory autopatcher.exe was run from. The backup location is c:\autopatcher.log

Since you don't have the rights to attach files yet just open the log file in a text editor of some kind and copy its contents into the chat box here.

MAKE SURE TO PUT IT BETWEEN SPOILER TAGS! Use the below line

Code: Select all

[spoiler] Your Text Goes Here [/spoiler]

ChrisJ
Posts: 351
Joined: Sun Oct 27, 2013 3:32 am

Re: Run-time error 13: Type mismatch

Postby ChrisJ » Mon Jun 27, 2016 2:43 am

Hi TAPG

I encountered the "run-time error 13" myself with ap6202, the same as user Bethrezen -> viewtopic.php?f=15&t=1382. Here's what I discovered... I had the MS Redist package loaded, official.

* clicking any apm text - windows addons title or any particular redist update, 2005, 2008, doesn't matter, all trigger the error dialog. I never was able to highlight an update to even click "more info". Strange though, I was able to select any or all check boxes, no problem. Also, \ap_temp\ is left behind, isn't deleted after AP closes.

The good news is, replacing 6202 with 6205 seems to do the trick, at least with regards to run-time error 13. I was able to click around without issue, clicking various update's "more info" would open my browser to the MS bulletin listed in the apm.

One aside - maybe we can have the Windows Addons apm link back to the AP forum rather than to microsoft.com. I will note though my release is somewhat outdated so there's a chance this has already been fixed - I guess I need to check :)

User avatar
TheAPGuy
Site Admin
Site Admin
Posts: 968
Joined: Sun Oct 27, 2013 12:38 am
Location: California
Contact:

Re: Run-time error 13: Type mismatch

Postby TheAPGuy » Mon Jun 27, 2016 4:12 am

Well... there was one function that dealt with converting text to Unicode that could output... ambiguous types if not directed to string only (which I did change it to after the complaint about the issue) however I didn't believe that it was the problem. I guess it was.

Well shit... Running the 6.2.2 exe itself does produce that error. Running the code through the debugger does not. I... What ever... its fixed. I am going to have to now try running the executable by itself after changes to see if errors pup up.

Well glad that fix did the trick. Will make it official ASAP.


Return to “Help”

Who is online

Users browsing this forum: No registered users and 1 guest